Kraken funding delays
Incident Report for Mesh Connect Status Page
Resolved
This incident has been resolved.
Posted Apr 15, 2024 - 20:07 UTC
Identified
Kraken has reported possible delays related to deposits and withdrawals. More details available here: https://status.kraken.com/incidents/qn6kc063myrj
Posted Apr 14, 2024 - 20:03 UTC
This incident affected: API.