Degraded service performance for Coinbase and Robinhood

Incident Report for Mesh Connect Status Page

Resolved

AWS team fixed the issue and all Coinbase and Robinhood operations are back to normal.
Posted Oct 21, 2025 - 06:46 UTC

Monitoring

While AWS teams implement the fixes, we're seeing that Coinbase operations are now working successfully. Our teams are closely monitoring the situation.
Posted Oct 20, 2025 - 13:02 UTC

Identified

Most AWS Service operations are succeeding normally now. We see some improvements in Coinbase's operations
Posted Oct 20, 2025 - 11:07 UTC

Update

We are continuing to monitor this issue.
Posted Oct 20, 2025 - 11:05 UTC

Investigating

We are currently experiencing degraded performance affecting integrations with Coinbase and Robinhood due to an ongoing AWS service disruption. The AWS team has identified the root cause and is actively working on a fix. We will provide updates as more information becomes available.
Posted Oct 20, 2025 - 11:00 UTC
This incident affected: Products (Mesh Pay, Mesh Verify, Mesh Deposits).